BIRDBRAIN 2002

Your browser is not capable of showing Java applets
Currently you must have Netscape 2.0+ or Internet Explorer running in Win9x, UNIX, or Mac/OS.

This applet is based on a classic game written long ago, on a platform not far away.

Comments, Problems, Suggestions

Last update 02/02/02